Notice of incident

Minor incident Print and report tool
2022-09-29 10:06 EST · 53 minutes

Updates

Resolved

The incident is now resolved.

We apologize for any inconvenience this incident may have caused.

September 29, 2022 · 10:59 EST
Issue

We’re currently experiencing issues with printing and transmitting clinical tools, printing patient labels and documents, and retrieving reports.

We are trying to correct the situation as soon as possible.

Thank you for your understanding.

September 29, 2022 · 10:08 EST

← Back