Notice of incident

Minor incident Services and external partners Lab results
2022-11-23 14:41 EDT · 12 hours, 18 minutes

Updates

Resolved

The incident is now resolved. All results have been delivered.

We apologize for any inconvenience this incident may have caused.

November 24, 2022 · 08:55 EDT
Investigating

Processing of new results (electronic and scanned) is back on track, but delayed due to high volume. The results will gradually enter the EMR over the next 4-5 hours.

November 23, 2022 · 15:31 EDT
Issue

We are currently experiencing problems with the import of lab results and the transmission of scanned results.

We are trying to resolve the situation as quickly as possible.

Thank you for your understanding.

November 23, 2022 · 14:44 EDT

← Back