Notice of incident - CNESST

Minor incident Services and external partners CNESST
2023-03-13 11:15 EDT · 1 hour, 15 minutes

Updates

Resolved

The incident has been resolved. The electronic transmission of the forms to the CNESST is operational since March 13 at 12:30 pm.

March 16, 2023 · 11:46 EDT
Issue

We are currently experiencing problems with the transmission of CNESST forms.

We have contacted the CNESST team to inform them. As soon as the problem is solved, the forms will be retransmitted automatically.

Thank you for your understanding.

March 13, 2023 · 11:55 EDT

← Back