Imaging requests missing in SAFIR

Minor incident Services and external partners SAFIR
2024-06-14 09:06 EDT · 1 hour, 1 minute

Updates

Resolved

The incident is now resolved. All systems are back to normal.

The situation status history is available below.

We apologize for any inconvenience this incident may have caused.

June 14, 2024 · 10:06 EDT
Issue

We would like to inform you that we are currently in communication with SAFIR regarding missing imaging requests (CRDS) from the request list.

We will keep you updated on the progress of the situation.

Thank you for your understanding.

June 14, 2024 · 09:06 EDT

← Back