Notice of incident

Minor incident Omnimed EMR
2024-09-26 10:44 EDT · 40 minutes

Updates

Resolved

The incident is now resolved. All systems are back to normal.

We apologize for any inconvenience this incident may have caused.

September 26, 2024 · 11:24 EDT
Issue

We’re currently experiencing delays in the Web EMR.

We’ll make our best to resolve the problem as soon as possible.

Thank you for your understanding.

September 26, 2024 · 10:44 EDT

← Back