Notice of incident

Minor incident Omnimed EMR
2025-06-12 14:35 EDT · 26 minutes

Updates

Resolved

All Google services are available. All systems are back to normal.

We apologize for any inconvenience this incident may have caused.

June 12, 2025 · 15:00 EDT
Issue

We’re currently experiencing logging issues when connecting to the EMR because of a downtime with some Google services.

We’re also experiencing issues when scanning documents.

We’ll make our best to resolve the problem as soon as possible.

This message will be updated as soon as more details are available.

Thank you for your understanding.

June 12, 2025 · 14:35 EDT

← Back