Notice of incident
Minor incident
Services and external partners
Customer service tools
2025-10-20 11:02 EDT
· 5 hours, 39 minutes
Updates
Resolved
October 20, 2025 · 16:41 EDT
The incident is now resolved. All systems are back to normal.
The situation status history is available below.
We apologize for any inconvenience this incident may have caused.
Issue
October 20, 2025 · 11:02 EDT
Our phone service provider is currently experiencing issues, and some calls may not reach our support team. If you need to contact us, please use the chat feature in the Omnimed application or email us at support@omnimed.com
This message will be updated as soon as new details become available.
Thank you for your understanding.
← Back
Application status