Notice of incident - Patient record merging
Minor incident
Patients records merging
2025-12-05 09:19 EST
· 3 days, 1 hour, 32 minutes
Updates
Resolved
December 8, 2025 · 10:51 EST
The incident is now resolved. All systems are back to normal.
We apologize for any inconvenience this incident may have caused.
Issue
December 5, 2025 · 09:19 EST
We are currently experiencing issues with patient record merging.
We are working to resolve the situation as quickly as possible. You may continue to submit your merge requests, but they will be processed once the incident is resolved.
This message will be updated as soon as new details become available.
Thank you for your understanding.
← Back
Application status