Minor incident Services and external partners Rx Vigilance
2022-01-17 13:00 EST · 19 hours, 59 minutes

Updates

Resolved

Access to RxVigilance is restored for all users.

January 18, 2022 · 08:59 EST
Issue

Access to RxVigilance is currently unavailable for some users and should be restored tomorrow.

January 17, 2022 · 13:51 EST

← Back