Incident affecting transmissions to the CNESST

Minor incident Services and external partners CNESST
2022-07-17 10:00 EDT · 1 day, 4 hours, 30 minutes

Updates

Resolved

The incident is now resolved. All pending CNESST forms have been forwarded.

July 18, 2022 · 15:18 EDT
Issue

An incident is currently affecting the electronic transmission of CNESST forms from Omnimed to CNESST.

July 18, 2022 · 09:11 EDT

← Back