Notice of incident

Minor incident Services and external partners Lab results
2022-07-28 21:00 EDT · 3 days, 11 hours, 4 minutes

Updates

Resolved

The incident is now resolved. All results involving a display problem were corrected on Friday, July 29.

August 1, 2022 · 08:04 EDT
Investigating

The incident is now resolved. All results involving a display problem were corrected on Friday, July 29.

August 1, 2022 · 08:03 EDT
Issue

We are currently experiencing problems with the display of lab results received electronically since yesterday, July 28, 2022 at 9:00 pm.

We are attempting to correct the situation as quickly as possible. The estimated time to resolve the issue is 4 hours.

Thank you for your understanding.

July 29, 2022 · 09:22 EDT

← Back